Page 4 of 7 FirstFirst 1234567 LastLast
Results 31 to 40 of 66

Thread: 74 FJ55

  1. #31
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    Plated the pig today

    But didn't get far

    Backfired so bad when I tried for third gear it blew the wimpy vacuum cap right off the HUGE 1/2" tube sticking outta the carb base. That led to cramming blue shop towel in there to get it limped back home - just!

    So I need to pull the carb right off ( I had done the top off to clean what I could ) and get serious about cleaning it up, also need to check the valve clearance & timing as it barks back through the carb if I blip the throttle. The ignition is all good & timing is on spec, I haven't checked the dist advance yet either...it's been 20 years since I did all this before EFI etc.

    Anyway my son was thrilled to get a ride in it after all this time & I needed to get it on the road for a burst of enthusiasm on my part


  2. #32
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    I'll stick it out...if all else fails there is an LS swap in my future

    Need to research the vaccume module on the inner fender, I think it's bunk.

  3. #33
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    Got some time in on the pig today, confirmed my distributor is vacuum retard not advance...so I ditched the vac line & she runs good, 32 deg total mech adv.

    Set the valves and took her down the block again, pulled good in third till it bogged out from the crap coming outta the tank...only getting a few miles out of each fuel filter till it (hopefully) settles down. no huge backfires anymore.

    Not happy with the brakes yet, won't really do a panic stop and pulls like hell...joys of 8 wheel cyl.

    Work on it some more this week & hope to drive it over to the SCCBC race next Sat.

  4. #34
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    Update - dropped the tank out on Sunday, no pic here yet but unbelievable huge chunks of rust & crap in there. The Leakers guy from Langley moved to Keremeos, anyone have a suggestion where to go locally with it?

    (I called a rad shop & they said they send them up to Leakers to get done...)

    Also need a fuel sender as mine is a glob of rust, unfortunately they are no longer available & different from the readily available FJ40 units.

    Last edited by ol yeller; 06-01-2015 at 10:01 PM. Reason: Mush brain

  5. #35
    OLC Member MatS's Avatar
    Join Date
    Dec 2010
    Location
    Langley, BC
    Posts
    892

    Default

    I don't know about where to send it if Richardson won't take it..... by the way they clean our plastic fuel tanks for warranty jobs :P

    I've heard good reviews of the POR 15 fuel tank coating system if that helps at all.

  6. #36
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    I'm going to take it by Fraser Valley Rad (? - across from B&B tire) tomorrow and see what they say. Meantime here are some pics 'cause everyone likes pics....

    what a difference doing a job like this standing under a hoist then laying on a creeper

    lines were very easy to get off, not baked hard like I was expecting.

    straps worked slick

    didn't look terminal looking in the filler hole, but this is actually the hump that goes over the crossmember not the bottom



    need a compatible sender or figure out a rebuild on this one

    i can't believe the HUGE chunks of crap & rust in here.

  7. #37
    Moderator CrimsonCruiser's Avatar
    Join Date
    Apr 2010
    Location
    Langley
    Posts
    341

    Default

    That's nasty!
    Is it possible to swap/retrofit in a 40 or a 60 tank and sender?
    '87 Land Cruiser HJ60
    '07 Tacoma TRD

  8. #38
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    Dropped the tank off this AM, not the cheapest but they are sending it up to Leakers for the clean & lining so it will hopefully outlast the rest of the heap

    Now I need to see about making a 40 sender work in my tank, they look almost identical so gotta research the ohms they operate at. Tank comes back in two weeks so hopefully I can actually get it more than a block from home after that


  9. #39
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    Bah lost my post after typing it all out.

    Got my sender apart, clean, and working on the bench. It has actually worn a hole in the shoe that slides on the winding

    Managed to drive the 55 off the hoist, pressure wash the bottom while the tank is out, then drive it back in to the hoist...try that with EFI even remembered to clean the crossmember just before packing up...I'm getting to that age I guess.
    Tank is back, looks like they opened up five 1" holes to clean it, sparkling new inside & a coat of black on the outside, good for another 40 yrs I hope.

    With some luck I'll have time & i hope to be driving it by Sat night

  10. #40
    OLC Member ol yeller's Avatar
    Join Date
    Sep 2010
    Location
    langley
    Posts
    299

    Default

    A few pics..

    Plug from cleaning hole


    Compare with the before shot, brand new inside


    Fuel sender, if you look close below you can see the hole worn through



    Last edited by ol yeller; 06-21-2015 at 09:35 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •